A Quick Fix for a minor GitLab GUI Error

So I recently encountered a weird error in the Admin Dashboard of GitLab:

No GitLab-Shell Version

It wasn’t a gitlab-shell error, the bin/check script ran fine. Git and Ruby at accepted versions from the rake gitlab:check command but it did show an error:

GitLab Shell version >= 1.7.9 ? ... FAIL. Please update gitlab-shell to 1.7.9 from Unknown

The fix is simple, a wrong path in gitlab.yml:

187   ## GitLab Shell settings
188     gitlab_shell:
189     path: /wrong/git/gitlab-shell/

(Some of the machine I administer use a different /home path.)

So, simply fix the path, restart gitlab and things will work.

Screenshot 2014-01-30 12.34.33

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.